Setup
- Retail POS for Mac or PC
Cause
- Loyalty is not enabled
- Customer is not enabled for loyalty
- Product is not enabled for loyalty
- Customer paid with store credit or loyalty
- Promotion without loyalty enabled
Solution
Check that loyalty is enabled
- Click Setup
- Click Loyalty
- Select Enable Loyalty
- Click Save
Check that customer is enabled for loyalty
- Click Customers
- Click the customer who did not earn loyalty
- Click Edit Customer
- Select Enable Loyalty for this Customer
- Click Save changes
Check that product is enabled for loyalty
- Click Products
- Click the products that were sold and did not accrue loyalty
- Click Edit Product
- Select Earn Default Loyalty
- If the product earns customer loyalty, select Earn Custom Loyalty and enter a number greater than zero
Check customer payment method
- Click sales history
- Find the sale where the customer did not earn loyalty
- If the payment method was store credit or loyalty, the customer will only earn loyalty on what they paid out of pocket
Check promotion settings
- Click Products
- Click Promotions
- Click Edit Promotion next to the promotion that is applied to the sale
- Enable Customers Can Earn Loyalty With This Promotion
- Click Save