Belangrijk
De volgende stappen moeten worden uitgevoerd door een technische gebruiker/webontwikkelaar die de expertise heeft om de eerste verbindingsproblemen met WooCommerce op te lossen.
Probleem
We konden je WooCommerce-winkel niet verbinden met Retail POS vanwege een probleem met de API-sleutel.
Configuratie
- Retail POS voor Mac of pc
- WooCommerce-integratie
Oorzaak
Dit wordt meestal veroorzaakt door een verkeerde configuratie van de WooCommerce-winkel. Controleer of de consumer key (consumentensleutel) en consumer secret (consumentencode) juist zijn.
Oplossing
Je moet het verzoekenlogboek downloaden en aan de beheerder van je winkel geven. Je kunt de volgende stappen ook laten uitvoeren door een technische gebruiker/webontwikkelaar die de expertise heeft om de eerste verbindingsproblemen met WooCommerce op te lossen.
-
Download en bekijk het logboek met verzoeken, als het antwoord retourneert met HTML, lees dan de HTML en kijk of je kunt bepalen waarom er geen JSON API-antwoord retourneert.
-
Als het antwoord gedeeltelijk JSON is, met HTML toegevoegd, dan is dit waarschijnlijk een intern probleem van WooCommerce of WordPress. We hebben dit in het verleden zien gebeuren met kapotte plugins. Controleer de HTML in het antwoord op fouten zoals PHP-waarschuwingen of -fouten.
-
Als het antwoord puur JSON is in de trant van {"code":"woocommerce_rest_cannot_view","message":"Sorry, je kunt geen lijst met bronnen weergeven.","data":{"status":401}}, dan wordt de authenticatie-informatie niet succesvol doorgegeven. Probeer om te beginnen de systeemstatus van de WooCommerce-installatie op te vragen via curl om te bevestigen dat het probleem dat je krijgt specifiek is voor de WooCommerce-installatie en niet voor Retail POS.
-
Voer de volgende opdracht uit in een terminal curl -vs --user YOUR_CONSUMER_KEY:YOUR_CONSUMER_SECRET https://YOUR_STORE.com/wp-json/wc/v2/system_status.
-
Als dit mislukt met een niet HTTP 401-statuscode, controleer dan de responsebody voor meer informatie
-
Als dit mislukt met een HTTP 401-statuscode, dan komt dit ofwel doordat de inloggegevens verkeerd zijn, of doordat de server verkeerd geconfigureerd is. Om te bepalen of het een probleem is met de serverconfiguratie, kun je proberen de referenties door te geven via queryparameters
-
curl -vs https://YOUR_STORE.com/wp-json/wc/v2/system_status?consumer_key=YOUR_CONSUMER_KEY&consumer_secret=YOUR_CONSUMER_SECRET
-
Als dit tweede commando een succesvol antwoord retourneert, is je server verkeerd geconfigureerd en accepteert deze de Authenticatie-header niet en moet dit worden opgelost. Om veiligheidsredenen geven we geen inloggegevens door via de query string-parameters. Als dit tweede commando ook mislukt, dan moet verder worden onderzocht waarom je WooCommerce-installatie de verstrekte inloggegevens niet accepteert. Ongeacht de uitkomst moet dit configuratieprobleem worden opgelost op de WooCommerce-server voordat je kunt integreren met Retail POS.