Problème
La publication des produits sur WooCommerce échoue en raison de la duplication des SKU.
Message d’erreur
Impossible de publier ce produit sur WooCommerce, car le SKU 111 est déjà utilisée par un produit sur WooCommerce synchronisé avec le SKU 222 dans Retail POS. Vous devrez changer le SKU de ce produit dans Retail POS ou changer le SKU du produit sur WooCommerce afin de pouvoir publier le produit.
Configuration
- Retail POS pour Mac ou PC
- Intégration WooCommerce
Cause
- Une variante de produit dans Retail POS a un SKU utilisé pour un produit standard dans WooCommerce.
- Un SKU de variante de produit dans Retail POS est utilisé sur deux variantes de produits dans deux familles de produits distinctes sur WooCommerce (c’est-à-dire que les SKU A et B renvoient à des variantes de produit différentes sur WooCommerce, mais à la même variante dans Retail POS).
- Plusieurs produits n’ont pas de SKU dans WooCommerce.
Solution
Changez le SKU du produit dans Retail POS ou du produit dans WooCommerce pour pouvoir publier ce produit.
- Cliquez sur Produits.
- Cliquez sur Exporter la liste.
- Consultez l’article Identification des SKU dupliqués dans un fichier de produits au format CSV.
- Mettez les produits à jour en leur attribuant un code SKU unique.
- Enregistrez le fichier CSV.
- Cliquez sur Produits.
- Cliquez sur Importer.
- Faites glisser le fichier CSV et déposez-le n’importe où sur la page.