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Impossible de connecter votre boutique WooCommerce, en raison d’un problème avec cette clé API

  Important

Les étapes suivantes doivent être effectuées par un utilisateur technique ou un développeur Web qui aura l’expertise nécessaire pour résoudre les problèmes de connexion initiale à WooCommerce.

Problème

Nous n’avons pas pu connecter votre boutique WooCommerce, car nous rencontrons un problème avec la clé API.

Configuration

  • Retail POS pour Mac ou PC
  • Intégration WooCommerce

Cause

Ce problème est généralement dû à une mauvaise configuration de la boutique WooCommerce. Veuillez vérifier que la clé consommateur et le secret consommateur sont corrects.

Solution

Vous devez télécharger le journal des requêtes pour le remettre à la personne qui gère votre boutique. Vous devez également vous assurer que les étapes suivantes sont effectuées par un utilisateur technique ou un développeur Web qui aura l’expertise nécessaire pour résoudre les problèmes de connexion initiale à WooCommerce.

  1. Téléchargez et consultez le journal des requêtes. Si la réponse est renvoyée en HTML, lisez le HTML et voyez si vous pouvez déterminer pourquoi aucune réponse API JSON n’est renvoyée.

  2. Si la réponse est partiellement renvoyée en JSON, accompagné de HTML, il s’agit probablement d’un problème interne à WooCommerce ou WordPress. Nous avons déjà constaté ce problème avec des modules d’extension défectueux. Vérifiez la présence d’alertes en PHP ou d’erreurs dans la réponse en HTML.

  3. Si la réponse est un JSON pur du type {"code":"woocommerce_rest_cannot_view","message":"Sorry, you cannot list resources.","data":{"status":401}‌, alors les informations d’authentification ne sont pas transmises correctement. Pour commencer, essayez de demander l’état du système de l’installation WooCommerce via curlpour confirmer que le problème que vous rencontrez est spécifique à l’installation WooCommerce et non à Retail POS.

  4. Exécutez la commande suivante dans un terminal : curl -vs --user YOUR_CONSUMER_KEY :YOUR_CONSUMER_SECRET https://YOUR_STORE.com/wp-json/wc/v2/system_status.

  5. Si cette opération échoue avec un code d’état autre que HTTP 401, veuillez examiner le corps de la réponse pour plus d’informations.

  6. Si l’opération échoue avec un code d’état HTTP 401, c’est soit parce que les identifiants sont incorrects, soit parce que le serveur est mal configuré. Pour déterminer s’il s’agit d’un problème de configuration du serveur, essayez de transmettre les informations d’identification via les paramètres de requête.

  7. curl -vs https://YOUR_STORE.com/wp-json/wc/v2/system_status?consumer_key=YOUR_CONSUMER_KEY&consumer_secret=YOUR_CONSUMER_SECRET

  8. Si cette deuxième commande renvoie une réponse positive, alors votre serveur est mal configuré et n’accepte pas l’en-tête d’authentification, ce qui doit être corrigé. Pour des raisons de sécurité, nous ne transmettons pas les identifiants via les paramètres de requête. Si cette deuxième commande échoue également, il faudra alors chercher à savoir pourquoi votre installation WooCommerce n’accepte pas les identifiants présentés. Quel que soit le résultat, ce problème de configuration doit être résolu sur le serveur WooCommerce avant de pouvoir intégrer WooCommerce à Retail POS.

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