Problem
Trying to send a register closure to Xero results in this error message: 'Bad request. A validation exception occurred -Account must be valid. Tax rate must be valid.
Setup
- Retail POS for Mac or PC
- Xero Integration
Cause
The account in Xero is archived or locked. The tax rates do not match between Retail POS and Xero.
Solution
Check for archived accounts:
- Click Setup
- Click Apps
- Click the pencil icon next to the Xero app to see your Xero settings
- Log into Xero
- Click Settings
- Click Chart of Accounts
- Click the archive tab
- Search for an account mapped in your Retail POS/Xero settings
- The account will appear in your search if it is archived
- Restore the account by clicking the checkbox
- Click Restore
Check for locked accounts:
- Click Setup
- Click Apps
- Click the pencil icon next to the Xero app to see your Xero settings
- Log into Xero
- Click Settings
- Click Chart of Accounts
- Search for an account mapped in your Retail POS/Xero settings
- The account name will have a padlock icon if it is locked
- Click here to learn how to resolve a locked account
Match Retail POS/Xero tax rates
- Click Setup
- Click Apps
- Click the pencil icon next to the Xero app to see your Xero settings
- Log into Xero
- Click Settings
- Click General Settings
- Click Tax Rates
- Check that each tax type in Retail POS has the same tax rate as the Xero tax it is mapped to
- To change the Xero tax rate mapped to Retail POS
- Click the drop-down in the Xero setup page
- Click a Xero tax that with the same rate as your Retail POS sales tax
Additional Information
If none of your Xero taxes match your Retail POS sales taxes, create a new tax rate in Xero with the same rate.
You will not be able to change your tax rates in Xero if they have been used in a transaction, are a locked tax rate, or are Tax Exempt (0%) or Sales Tax on Imports. You can learn more about editing tax rates in Xero here.