Problem
Products failing to publish to WooCommerce due to duplicate SKUs.
Error message
Unable to publish this product to WooCommerce because the SKU 111 is already used by a product in WooCommerce that is syncing with the SKU 222 in Retail POS. You will need to change the SKU of this product in Retail POS or change the SKU of the product in WooCommerce to something different to be able to publish the product.
Setup
- Retail POS for Mac or PC
- WooCommerce Integration
Cause
- A Retail POS variant has a SKU that's used on a standard product in WooCommerce
- A Retail POS variant SKU is used on two variants across two separate product families on WooCommerce (i.e. SKU A & B are on different variants on WooCommerce, but the same variant in Retail POS)
- More than one product is missing the SKU on WooCommerce
Solution
Change the SKU of the product in Retail POS or the product in WooCommerce to something different to be able to publish this product.
- Click Products
- Click Export List
- How to find duplicate SKUs in a product CSV file
- Update the products to a unique SKU value
- Save the CSV file
- Click Products
- Click Import
- Drag and drop the CSV file anywhere