Problem
Register closures and on account sales are not automatically posting to Xero.
Setup
- Retail POS for Mac or PC
- Xero integration
Cause
- There are errors preventing posting to Xero
- Xero account is not authorised
- Arabic characters in the Invoice Prefix and Suffix and the register name
- Multiple Xero connections under the Xero settings
Solution
Check for Errors Posting to Xero
- Find the register closure/on account sale that is not posting to Xero
- Click the red 'Xero' icon next to the register closure/sale
- Check the error that appears.
If the 'Xero' icon turns blue, it means there was an error at the time the register closure/on account sale was created. The error has since been resolved but Retail POS will not send the register closure/on account sale over to Xero again automatically. You will need to click the red Xero icon to send them over.
Authorise Xero Account
- Click Setup
- Click Apps
- Click the pencil next to the Xero icon
- Click your organisation name at the bottom right
- Log in with your Xero credentials
Arabic characters in the Invoice number field and the register name
- Click Setup
- Click Outlets and Registers
- Click Edit Register
- Change the Register name and the Invoice Prefix and Suffix to English
Multiple Xero connections under the Xero settings
- In Xero, click the organisation name in the top right
- Click App Marketplace
- Click Connected
- If there is more than one Retail POS app connected, click Disconnect app
Additional Information