Hi. How can we help?

Inventory levels aren't updating when importing product CSV

Problem

While importing a CSV file to update inventory, the stock levels don't change and are still displaying as an infinity symbol in Retail POS. 

Setup

  • Retail POS for Mac or PC

Cause

The inventory tracking is not enabled for the products.

Solution

You would need to first enable inventory tracking for your products in Retail POS. You can do so either through Retail POS's Add/Edit Product page or through importing a CSV file.

Through the Add/Edit Product page

You can enable tracking inventory for each product individually. To do so, you would need to follow the steps below:

  1. Navigate to Catalog -> Products
  2. Click on the name of the product you wish to enable inventory tracking
  3. Click Edit Product
  4. Scroll down to Inventory
  5. Select Track Inventory for this Product
  6. Click Save

Through CSV Import

You can enable inventory tracking through a CSV import:

  1. Navigate to Catalog -> Products
  2. Click on Export List to export a CSV file of all your products
  3. On your CSV file, change the value of the "track_inventory" column to 1 for the products you want to track inventory for
  4. Make sure you have the correct inventory level on your file and save the file as CSV
  5. Import the CSV file onto your Retail POS store

Additional Information

How to enable inventory tracking through CSV

Was this article helpful?