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Xero Error: Payments can only be made against Authorised documents

Problem

Sending an on-account sale to Xero returns the error: "Payments can only be made against authorised documents"

Setup

  • Retail POS for Mac or PC
  • Xero Integration

Cause

  • Invoice is not approved in Xero
  • On account sales have payments on them before invoice is pushed through to Xero

Solution

Invoice is not approved in Xero

  1. Click Sales history
  2. Click the sale you need to sync to Xero
  3. Click Xero
  4. Click View on Xero
  5. Click Approve 

On account sales have payments on them before invoice posted to Xero 

  • If a payment is applied to an on account sale before it has been posted to Xero, the sale can be voided and recreated, or;
  • the payment removed from the sale and re-applied after posting to Xero.

Additional Information

To prevent this error from occurring, set invoices to post to Xero as approved in your Retail POS/Xero settings. 

 

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