Problem
Receiving a printing error "failed to open port" after completing a sale.
Setup
- Retail POS on iPad
Cause
Retail POS is trying to connect to more than one printer or the Retail POS iPad App needs updating.
Solution
- Tap the menu icon in the top left corner of your Retail POS app
- Tap Settings
- Tap Hardware
- Tap on the printers in the list and check that they are all connected
- Remove the printers that are not connected
If the steps above do not work, you will have to reset the network settings on the iPad.
To Reset Network Settings
- Go to iPad Settings
- Go to General > Transfer or Reset [Device] > Reset > Reset Network Settings
- Type in the password for the device and the device will restart.
- Go to Wi-fi and reconnect to the network
Go back to the Retail POS App, remove the printer, and re-add it.
Last Resort
1. Turn off your printer and unplug the power cable.
2. Leave the printer still connected to your router. Your router should not be powered off.
3. Turn your printer over and locate the small dip switch panel on the underside of the printer.
4. Using a Philips head screwdriver, remove the single screw. The panel sometimes is screwed on very tightly by the factory and can take some effort to unscrew. It is very important you have the right-sized screwdriver to prevent damaging the screw head when applying effort.
5. Assuming the printer is oriented with the back of the printer (the side with the power, cash drawer, and Ethernet ports) at the “12 o’clock” position, your printer dip switches will be all set to the left side.
6. Using a pen tip, set the dip switches to the opposite side (i.e., the right side).
7. Screw the dipswitch panel back on.
8. Turn the printer back to its upright position.
9. Make sure the power switch is still off and plugin printer into the wall socket. Make sure the powered router is still connected.
10. Put your finger on the Feed button and click the power switch on. Do not release the Feed button until your printer starts to make some noise. Release the Feed button when your printer starts to make some noise. It prints two papers.
11. Verify the second paper indicates a DHCP IP address like 10.0.1.2.
12. Turn off your printer and unplug the power cable again.
13. Turn your printer over and reopen the small dip switch panel.
14. Set the dip switches back to their original position (that is the opposite of what they are currently).
15. Screw the dipswitch panel back on.
16. Power on your printer.
17. You can now set your thermal printer to a proper IP address!
Additional Information
A printer will show as connected when the IP address and printer model information is recorded in the printer settings.
To remove a printer, tap the printer you wish to remove. The Remove printer button is at the bottom of the Edit printer pop-up.
To update your Retail POS iPad App, follow the steps here.