Hi. How can we help?

Importing products from WooCommerce into Retail POS (X-Series) is duplicating the attributes in WooCommerce

Problem

When importing products with two or more attributes from WooCommerce into Retail POS, a duplicate attribute is created in WooCommerce.

Setup

  • Retail POS for Mac or PC
  • WooCommerce Integration 

Cause

This happens when the variants for products don't have unique SKUs. 

Solution

To prevent it from happening, ensure each variation has a unique SKU assigned to it before importing the products into Retail POS.

To correct this issue, delete the duplicated attribute on WooCommerce. 

 

Was this article helpful?