Hi. How can we help?

The Product edit page does not load when trying to edit a product with variants

Problem

When trying to edit a product with variants, the edit page does not load and it also does not show any errors.

Setup

  • Retail POS for Mac or PC

Cause

There is missing information in the variant value and one of the variant items is missing a variant value. 

Solution

The mismatch needs to be corrected for the product through a CSV import by following the steps below:

  • Navigate to Catalog -> Products
  • Search for the affected product by its name or handle
  • Export the CSV file by clicking on Export List
  • On the CSV file, enter any missing values for the variant items
  • Remove the inventory level columns and save the file in a .csv format again
  • Import this file back into your Product page by clicking on Import

Once the import is completed the product would be accessible to be edited/updated.

Additional Information

When there are missing variants attributes or mismatch between the variant attributes, an error would appear on the screen when trying to edit the product as "Something went wrong with this product". These issues are address below:

Was this article helpful?