Problem
The payment was approved on a payment terminal, but the sale is still awaiting payment on the Sell Screen on Retail POS.
Setup
- Retail POS for Mac or PC
- Retail POS on iPad
-
Integrated payment terminal
- Worldpay Integrated Payments, Worldpay TriPOS, PayPal, Square, Moneris, Chase,
Tyro, Payment Express, Commonwealth Bank, Smartpay, National Australia Bank,
Zettle, Sum Up, Paymentsense, Verifone and Yoco
- Worldpay Integrated Payments, Worldpay TriPOS, PayPal, Square, Moneris, Chase,
Cause
The payment terminal has failed to send approval back to Retail POS.
In some situations, you may run a sale through your payment terminal which is accepted, but Retail POS does not receive the confirmation. This usually occurs because of poor Wi-Fi speeds or the connectivity between your terminal and your Mac, PC or iPad.
Solution
- Contact your payment provider to confirm if the customer was charged or not
- If the customer WASN'T charged, process the payment again as normal
- If the customer WAS charged, proceed to step 2
- Click Pay, add the amount then select Cash
- Navigate to Sell -> Sales History
- Locate the sale and expand it
- Click Edit
- Change Payment Type as required
- Select the payment date and time from the Date drop-down
- Click Save
Additional Information
- These steps will record the payment in Retail POS, but this will not charge the customer. Your payment provider will be able to confirm if the charge was approved or not
- If this issue is persistent, contact your terminal providers support team or reach out to Retail POS support